Repository navigation
couchdb pkg svc fails to start #211
Copy link
Copy link
Closed
Description
Activity
Unless there is a bug in the package these two things should be unrelated. Nothing in packages should be writing to
/usr, and in any case/usris a read-only mount from the global zone so can't be written to anyway.Package data should be limited to
/opt/localfor package files and/varfor any user-generated data.If the test package I posted on smartos-discuss is still causing errors here then please could you post some more detailed logs and we can take a look at where they may be coming from.
- added a commit that references this issue
on Dec 15, 2019 - added 2 commits that reference this issue
on Mar 25, 2020 - added a commit that references this issue
on May 3, 2020 - added a commit that references this issue
on Sep 16, 2020 - added a commit that references this issue
on Jun 4, 2021 - added a commit that references this issue
on Jul 22, 2021 55 remaining items
- added 10 commits that reference this issue
on May 14, 2026 - added 2 commits that reference this issue
on May 22, 2026 - added a commit that references this issue
on Jun 2, 2026 - added a commit that references this issue
on Aug 25, 2026
Metadata
Metadata
Assignees
Labels
No labels
Vanilla smartOS zone latest x86_base64 image.
run ‘pkgin up -fy’
run ‘pkgin in -y couchdb’
Installs packages properly but fails to start with erlang errors pertaining to read only filesystems full such as /usr. Unable to start erlang monitoring processes. erlang kernel error.
will post output of errors upon request.
Also ‘svcadm enable -r couchdb’
Fails to enable couch-epmd dependency by default prior to enabling couchdb this must be done manually and then must have couchdb restarted after.