Skip to content

2022Q4 bind-9.18 is broken #352

Description

@bahamat

The SMF service is unable to start.

[ Jan 12 18:17:35 Executing start method ("/opt/local/lib/svc/method/named start default"). ]
/opt/local/lib/svc/method/named[225]: /opt/local/sbin/named-checkconf: not found [No such file or directory]
named: named-checkconf failed to verify configuration
[ Jan 12 18:17:35 Method "start" exited with status 96. ]

The file has been moved:

# ls -l /opt/local/bin/named-checkconf
-rwxr-xr-x 1 root root 65920 Jan  5 20:02 /opt/local/bin/named-checkconf*

The 9.16 version the file is still in sbin and the service starts up normally.

Activity

  1. self-assigned this
    on Jan 16, 2023
  2. jperkin commented on Jan 16, 2023

    @jperkin
    Collaborator

    Fixed upstream and backported to 2022Q4 in bind-9.18.9nb2.

  3. added a commit that references this issue on Mar 12, 2023
  4. added a commit that references this issue on Jan 9, 2024
  5. added a commit that references this issue on Jan 25, 2024
  6. added a commit that references this issue on Mar 4, 2024
  7. added a commit that references this issue on May 10, 2024
  8. added a commit that references this issue on Sep 24, 2024
  9. 16 remaining items

  10. added a commit that references this issue on May 22, 2026
  11. added a commit that references this issue on Sep 13, 2026
  12. added a commit that references this issue on Sep 28, 2026
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

Labels

No labels
No labels

Type

No type

Projects

No projects

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions