Steps to reproduce
- Upload a file through the webinterface or the desktop-sync-client
file size seems to be irrelevant, but it is possible to create and edit a textfile with the webinterface-texteditor until its some 100B big.
Expected behaviour
The file should be uploaded and shown in the webinterface.
Actual behaviour
The desktop-client throws an error, that the server closed/interrupted the connection, the webclient stop after a while and reloads the site.
It seems that this error happend also some time ago with ownCloud, but no of the suggested patches worked for me. This guy has the same issue with Nextcloud 10: https://help.nextcloud.com/t/400-expected-filesize-exception/2835
Server configuration
Operating system: Debian 8
Web server: Apache 2.4.10
Database: MySQL 5.5.50
PHP version: 5.6.24
Nextcloud version: 10.0.0
Updated from an older Nextcloud/ownCloud or fresh install: Upgrade from Nextcloud 9.
Where did you install Nextcloud from: Upgrade from the latest release before Nextcloud 10
Signing status:
Signing status
No errors have been found.
List of activated apps:
App list
- activity: 2.3.2
- admin_audit: 1.0.0
- calendar: true
- comments: 1.0.0
- contacts: true
- dav: 1.0.0
- documents: 0.13.1
- federatedfilesharing: 1.0.1
- federation: 1.0.1
- files: 1.5.2
- files_external: 1.0.2
- files_pdfviewer: 0.8.1
- files_retention: 1.0.0
- files_sharing: 1.0.0
- files_texteditor: 2.1
- files_trashbin: 1.0.0
- files_versions: 1.3.0
- files_videoplayer: 0.9.8
- gallery: 15.0.0
- notifications: 0.3.0
- password_policy: 1.0.0
- provisioning_api: 1.0.0
- serverinfo: 1.1.1
- survey_client: 0.1.5
- systemtags: 1.0.2
- tasks: 0.9.3
- templateeditor: 0.1
- theming: 1.0.1
- user_external: 0.4
- workflowengine: 1.0.1
Config report
{
"system": {
"instanceid": "ocgpq3w3pspp",
"passwordsalt": "_REMOVED SENSITIVE VALUE",
"secret": "_REMOVED SENSITIVE VALUE",
"trusted_domains": [
"owncloud.mydomain"
],
"datadirectory": "/var/owncloud-data",
"overwrite.cli.url": "https://owncloud.mydomain",
"dbtype": "mysql",
"version": "9.1.0.16",
"dbname": "owncloud",
"dbhost": "localhost",
"dbtableprefix": "oc_",
"dbuser": "_REMOVED SENSITIVE VALUE",
"dbpassword": "_REMOVED SENSITIVE VALUE",
"installed": true,
"forcessl": true,
"forceSSLforSubdomains": false,
"mail_from_address": "owncloud",
"mail_smtpmode": "php",
"mail_domain": "mydomain",
"loglevel": 0,
"maintenance": false,
"memcache.local": "\OC\Memcache\APCu",
"theme": "",
"htaccess.RewriteBase": "/",
"updater.release.channel": "production"
}
}
Are you using external storage, if yes which one: no
Are you using encryption: no
Are you using an external user-backend, if yes which one: no
Client configuration
Browser: Firefox 48.0.2
Operating system: Windows 10
Logs
Web server error log
Web server error log
The Webserver doesn´t log anything in its error log
#### Nextcloud log (data/nextcloud.log)
Nextcloud log
Exception: {"Message":"HTTP/1.1 400 expected filesize 615342 got 0","Exception":"Sabre\DAV\Exception\BadRequest","Code":0,"Trace":"#0 /var/www/owncloud/apps/dav/lib/Connector/Sabre/Directory.php(137): OCA\DAV\Connector\Sabre\File->put(Resource id #96)\n#1 /var/www/owncloud/3rdparty/sabre/dav/lib/DAV/Server.php(1036): OCA\DAV\Connector\Sabre\Directory->createFile('IMG_1051.jpg', Resource id #96)\n#2 /var/www/owncloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php(523): Sabre\DAV\Server->createFile('sonstiges/IMG_1...', Resource id #96, NULL)\n#3 [internal function]: Sabre\DAV\CorePlugin->httpPut(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#4 /var/www/owncloud/3rdparty/sabre/event/lib/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#5 /var/www/owncloud/3rdparty/sabre/dav/lib/DAV/Server.php(459): Sabre\Event\EventEmitter->emit('method:PUT', Array)\n#6 /var/www/owncloud/3rdparty/sabre/dav/lib/DAV/Server.php(248): Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#7 /var/www/owncloud/apps/dav/appinfo/v1/webdav.php(60): Sabre\DAV\Server->exec()\n#8 /var/www/owncloud/remote.php(165): require_once('/var/www/ownclo...')\n#9 {main}","File":"/var/www/owncloud/apps/dav/lib/Connector/Sabre/File.php","Line":150,"User":"##myusername##"}
#### Browser log
Browser log
Cause the error happen in the backend (WebDAV-client is irrelevant), I don´t include it.
Steps to reproduce
file size seems to be irrelevant, but it is possible to create and edit a textfile with the webinterface-texteditor until its some 100B big.
Expected behaviour
The file should be uploaded and shown in the webinterface.
Actual behaviour
The desktop-client throws an error, that the server closed/interrupted the connection, the webclient stop after a while and reloads the site.
It seems that this error happend also some time ago with ownCloud, but no of the suggested patches worked for me. This guy has the same issue with Nextcloud 10: https://help.nextcloud.com/t/400-expected-filesize-exception/2835
Server configuration
Operating system: Debian 8
Web server: Apache 2.4.10
Database: MySQL 5.5.50
PHP version: 5.6.24
Nextcloud version: 10.0.0
Updated from an older Nextcloud/ownCloud or fresh install: Upgrade from Nextcloud 9.
Where did you install Nextcloud from: Upgrade from the latest release before Nextcloud 10
Signing status:
Signing status
No errors have been found.
List of activated apps:
App list
Config report
{
"system": {
"instanceid": "ocgpq3w3pspp",
"passwordsalt": "_REMOVED SENSITIVE VALUE",
"secret": "_REMOVED SENSITIVE VALUE",
"trusted_domains": [
"owncloud.mydomain"
],
"datadirectory": "/var/owncloud-data",
"overwrite.cli.url": "https://owncloud.mydomain",
"dbtype": "mysql",
"version": "9.1.0.16",
"dbname": "owncloud",
"dbhost": "localhost",
"dbtableprefix": "oc_",
"dbuser": "_REMOVED SENSITIVE VALUE",
"dbpassword": "_REMOVED SENSITIVE VALUE",
"installed": true,
"forcessl": true,
"forceSSLforSubdomains": false,
"mail_from_address": "owncloud",
"mail_smtpmode": "php",
"mail_domain": "mydomain",
"loglevel": 0,
"maintenance": false,
"memcache.local": "\OC\Memcache\APCu",
"theme": "",
"htaccess.RewriteBase": "/",
"updater.release.channel": "production"
}
}
Are you using external storage, if yes which one: no
Are you using encryption: no
Are you using an external user-backend, if yes which one: no
Client configuration
Browser: Firefox 48.0.2
Operating system: Windows 10
Logs
Web server error log
Web server error log
The Webserver doesn´t log anything in its error log
Nextcloud log
Exception: {"Message":"HTTP/1.1 400 expected filesize 615342 got 0","Exception":"Sabre\DAV\Exception\BadRequest","Code":0,"Trace":"#0 /var/www/owncloud/apps/dav/lib/Connector/Sabre/Directory.php(137): OCA\DAV\Connector\Sabre\File->put(Resource id #96)\n#1 /var/www/owncloud/3rdparty/sabre/dav/lib/DAV/Server.php(1036): OCA\DAV\Connector\Sabre\Directory->createFile('IMG_1051.jpg', Resource id #96)\n#2 /var/www/owncloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php(523): Sabre\DAV\Server->createFile('sonstiges/IMG_1...', Resource id #96, NULL)\n#3 [internal function]: Sabre\DAV\CorePlugin->httpPut(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#4 /var/www/owncloud/3rdparty/sabre/event/lib/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#5 /var/www/owncloud/3rdparty/sabre/dav/lib/DAV/Server.php(459): Sabre\Event\EventEmitter->emit('method:PUT', Array)\n#6 /var/www/owncloud/3rdparty/sabre/dav/lib/DAV/Server.php(248): Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#7 /var/www/owncloud/apps/dav/appinfo/v1/webdav.php(60): Sabre\DAV\Server->exec()\n#8 /var/www/owncloud/remote.php(165): require_once('/var/www/ownclo...')\n#9 {main}","File":"/var/www/owncloud/apps/dav/lib/Connector/Sabre/File.php","Line":150,"User":"##myusername##"}
Browser log
Cause the error happen in the backend (WebDAV-client is irrelevant), I don´t include it.