Skip to content

Nextcloud 11 - Upgrade to 12 failed -  #6410

Description

@sebthesun

Hi,
I tried to upgrade my Nextcloud 11 to 12 with the web updater but, at the end, I got this error:

Mise à jour du schéma de la base de données
Doctrine\DBAL\Exception\DriverException: An exception occurred while executing 'ALTER TABLE oc_filecache ALTER mtime TYPE INT': SQLSTATE[22003]: Numeric value out of range: 7 ERROR:
integer out of range

Before update version : 11.0.4

Steps to reproduce

1.Simply follow the set in the upgrade process with the Updater

Expected behaviour

A functional Nextcloud 12 installation

Actual behaviour

Upgrade fail with an sql error

Server configuration

UBUNTU 16.04.3 x86_64

APACHE 2.4.18

PostgreSQL 9.5

PHP 7.0.22

nextcloud 11.0.4

fresh install

int

Signing status:

Signing status

Not available, unable to log in

List of activated apps:

App list Enabled: - activity: 2.4.1 - calendar: 1.5.3 - comments: 1.1.0 - dav: 1.1.1 - federatedfilesharing: 1.1.1 - federation: 1.1.1 - files: 1.6.1 - files_pdfviewer: 1.0.1 - files_sharing: 1.1.1 - files_texteditor: 2.2 - files_trashbin: 1.1.0 - files_versions: 1.4.0 - files_videoplayer: 1.0.0 - firstrunwizard: 2.0 - gallery: 16.0.0 - logreader: 2.0.0 - lookup_server_connector: 1.0.0 - nextcloud_announcements: 1.0 - notifications: 1.0.1 - password_policy: 1.1.0 - provisioning_api: 1.1.0 - richdocuments: 1.11.33 - serverinfo: 1.1.1 - sharebymail: 1.0.1 - spreed: 1.2.0 - spreedme: 0.3.9 - survey_client: 0.1.5 - systemtags: 1.1.3 - theming: 1.1.1 - twofactor_backupcodes: 1.0.0 - twofactor_totp: 1.1.0 - updatenotification: 1.1.1 - workflowengine: 1.1.1 Disabled: - admin_audit - encryption - external - files_accesscontrol - files_automatedtagging - files_external - files_retention - templateeditor - user_external - user_ldap - user_saml

Nextcloud configuration:

Config report { "system": { "instanceid": "ocdn8gq560uz", "passwordsalt": "***REMOVED SENSITIVE VALUE***", "secret": "***REMOVED SENSITIVE VALUE***", "trusted_domains": [ "nc.example.com" ], "datadirectory": "\/var\/www\/nc.example.com\/data", "overwrite.cli.url": "https:\/\/nc.example.com", "dbtype": "pgsql", "version": "11.0.1.2", "dbname": "nc_example_com", "dbhost": "localhost", "dbport": "", "dbtableprefix": "oc_", "dbuser": "***REMOVED SENSITIVE VALUE***", "dbpassword": "***REMOVED SENSITIVE VALUE***", "logtimezone": "UTC", "installed": true, "maintenance": false, "updater.secret": "***REMOVED SENSITIVE VALUE***", "theme": "", "loglevel": 2 } }

Are you using external storage, if yes which one: no
Are you using encryption: no

Are you using an external user-backend, if yes which one: no

Activity

  1. MorrisJobke commented on Sep 7, 2017

    @MorrisJobke
    Member

    Looks like #2775

  2. MorrisJobke commented on Sep 29, 2017

    @MorrisJobke
    Member

    @nickvergessen: Do you have in idea what this is?

  3. MorrisJobke commented on Sep 29, 2017

    @MorrisJobke
    Member

    @sebthesun Could you provide the table definition from your postgres DB? Something like this will show it:

    \d+ oc_filecache
    
  4. sebthesun commented on Oct 19, 2017

    @sebthesun
    Author

    oc_filecache

    Sorry for the image, I didn't found the way to paste the text and keeping the format.

  5. MorrisJobke commented on Jan 2, 2018

    @MorrisJobke
    Member

    @nickvergessen another DB issue :/

  6. nickvergessen commented on Jan 4, 2018

    @nickvergessen
    Member

    Hmm, I'm not an expert for postgres, but it looks like integer columns have not size on postgres?
    But the question is, why is it trying to update it anyway, because the Schema didn't change.

    Side note: We changed the table for 13 to be bigint. So there should be no "integer out of range" error anymore.

  7. MorrisJobke commented on Oct 29, 2018

    @MorrisJobke
    Member

    As there is no feedback since a while I will close this ticket. If this is still happening please feel free to reopen.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions