@@ -3022,8 +3022,7 @@ changes:
30223022Checks whether the certificate matches the given email address.
30233023
30243024If the ` 'subject' ` option is undefined or set to ` 'default' ` , the certificate
3025- subject is only considered if the subject alternative name extension either does
3026- not exist or does not contain any email addresses.
3025+ subject is considered according to OpenSSL's default behavior.
30273026
30283027If the ` 'subject' ` option is set to ` 'always' ` and if the subject alternative
30293028name extension either does not exist or does not contain a matching email
@@ -3067,9 +3066,7 @@ comparisons are case-insensitive, the returned subject name might also differ
30673066from the given ` name ` in capitalization.
30683067
30693068If the ` 'subject' ` option is undefined or set to ` 'default' ` , the certificate
3070- subject is only considered if the subject alternative name extension either does
3071- not exist or does not contain any DNS names. This behavior is consistent with
3072- [ RFC 2818] [ ] ("HTTP Over TLS").
3069+ subject is considered according to OpenSSL's default behavior.
30733070
30743071If the ` 'subject' ` option is set to ` 'always' ` and if the subject alternative
30753072name extension either does not exist or does not contain a matching DNS name,
@@ -7538,7 +7535,6 @@ See the [list of SSL OP Flags][] for details.
75387535[ Permission Model ] : permissions.md#permission-model
75397536[ RFC 1421 ] : https://www.rfc-editor.org/rfc/rfc1421.txt
75407537[ RFC 2409 ] : https://www.rfc-editor.org/rfc/rfc2409.txt
7541- [ RFC 2818 ] : https://www.rfc-editor.org/rfc/rfc2818.txt
75427538[ RFC 3526 ] : https://www.rfc-editor.org/rfc/rfc3526.txt
75437539[ RFC 3610 ] : https://www.rfc-editor.org/rfc/rfc3610.txt
75447540[ RFC 4055 ] : https://www.rfc-editor.org/rfc/rfc4055.txt
0 commit comments