@@ -3013,8 +3013,7 @@ changes:
30133013Checks whether the certificate matches the given email address.
30143014
30153015If the ` 'subject' ` option is undefined or set to ` 'default' ` , the certificate
3016- subject is only considered if the subject alternative name extension either does
3017- not exist or does not contain any email addresses.
3016+ subject is considered according to OpenSSL's default behavior.
30183017
30193018If the ` 'subject' ` option is set to ` 'always' ` and if the subject alternative
30203019name extension either does not exist or does not contain a matching email
@@ -3058,9 +3057,7 @@ comparisons are case-insensitive, the returned subject name might also differ
30583057from the given ` name ` in capitalization.
30593058
30603059If the ` 'subject' ` option is undefined or set to ` 'default' ` , the certificate
3061- subject is only considered if the subject alternative name extension either does
3062- not exist or does not contain any DNS names. This behavior is consistent with
3063- [ RFC 2818] [ ] ("HTTP Over TLS").
3060+ subject is considered according to OpenSSL's default behavior.
30643061
30653062If the ` 'subject' ` option is set to ` 'always' ` and if the subject alternative
30663063name extension either does not exist or does not contain a matching DNS name,
@@ -7516,7 +7513,6 @@ See the [list of SSL OP Flags][] for details.
75167513[ Permission Model ] : permissions.md#permission-model
75177514[ RFC 1421 ] : https://www.rfc-editor.org/rfc/rfc1421.txt
75187515[ RFC 2409 ] : https://www.rfc-editor.org/rfc/rfc2409.txt
7519- [ RFC 2818 ] : https://www.rfc-editor.org/rfc/rfc2818.txt
75207516[ RFC 3526 ] : https://www.rfc-editor.org/rfc/rfc3526.txt
75217517[ RFC 3610 ] : https://www.rfc-editor.org/rfc/rfc3610.txt
75227518[ RFC 4055 ] : https://www.rfc-editor.org/rfc/rfc4055.txt
0 commit comments