Skip to content

nspawn container fails to start #9563

Description

@tkolo

systemd version the issue has been seen with
v239, on the host, v229 on the guest

Used distribution
Gentoo linux on the host, Ubuntu 16.04 LTS on the guest

Expected behaviour you didn't see
Correct start of the container

Unexpected behaviour you saw

helvete(6a95e933da71409c8ca481b27688da88)
           Since: Tue 2018-07-10 22:00:13 CEST; 2min 36s ago
          Leader: 1449 (systemd)
         Service: systemd-nspawn; class container
            Root: /var/lib/machines/helvete
           Iface: vpn
       UID Shift: 1684668416
            Unit: [email protected]
                  ├─payload
                  │ └─1449 /lib/systemd/systemd
                  └─supervisor
                    └─1381 /usr/bin/systemd-nspawn --quiet --keep-unit --boot --link-journal=try-guest --network-veth -U --settings=override --machine=helvete

lip 10 22:00:46 hell systemd-nspawn[1381]: [1B blob data]
lip 10 22:00:46 hell systemd-nspawn[1381]: Welcome to Ubuntu 16.04.4 LTS!
lip 10 22:00:46 hell systemd-nspawn[1381]: [1B blob data]
lip 10 22:00:48 hell systemd-nspawn[1381]: Set hostname to <helvete>.
lip 10 22:00:48 hell systemd-nspawn[1381]: Failed to read AF_UNIX datagram queue length, ignoring: No such file or directory
lip 10 22:00:48 hell systemd-nspawn[1381]: Failed to install release agent, ignoring: No such file or directory
lip 10 22:00:48 hell systemd-nspawn[1381]: Failed to create /init.scope control group: Permission denied
lip 10 22:00:48 hell systemd-nspawn[1381]: Failed to allocate manager object: Permission denied
lip 10 22:00:48 hell systemd-nspawn[1381]: [!!!!!!] Failed to allocate manager object, freezing.
lip 10 22:00:48 hell systemd-nspawn[1381]: Freezing execution.

Steps to reproduce the problem
I'm not sure, I didn't try with another containers. All I did is:

  • Create a container on a previous version of systemd
  • Update systemd to v239
  • Reboot to make sure upgrade is in place
  • Attempt restarting the container

Reverting systemd on the host to v238 solves the issue.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions