Repository navigation
nspawn: chown() the legacy hierarchy when it's used in a container - #10104
Conversation
|
@evverx I can confirm this fixes the issue for me - systemd 230 in the container, systemd 239 plus your patch on top. Containers with a recent systemd still work, too. Thanks a lot! |
|
Given the "dont-merge" label: How is this PR intended? Do you want to collect more feedback? Is that a workaround that won't get merged in? |
|
The PR is ready to be merged. I just forgot to remove the label after I made sure that it worked. Thank you for checking it out and for the nudge! |
|
ok, thanks for the clarification. Looking forward to the merge, and a release containing the fix ;-) |
|
It make sense to also push this to https://github.com/systemd/systemd-stable/commits/v239-stable |
|
I also tested this patch. |
This fixes nspawn containers with older systemd inside currently failing to start. See: NixOS/systemd#23 systemd/systemd#10104 NixOS#47253
This fixes nspawn containers with older systemd inside currently failing to start. See: NixOS/systemd#23 systemd/systemd#10104 #47253
This fixes nspawn containers with older systemd inside currently failing to start. See: NixOS/systemd#23 systemd/systemd#10104 #47253 (cherry picked from commit c3cc34f)
|
It's impressive that the patch has already been downstreamed without even making it upstream :-) @poettering could you take a look so that we could catch up with NixOS folks? |
|
@evverx hah, that's mostly due to NixOS 18.09 release being around the corner, shipping with 239, and not wanting to break existing nspawn setups - but thanks :-) |
This is a follow-up to 720f0a2.
Closes #10026
Closes #9563